(not at the head of any monitored branch or PR)
2023-11-20 17:36.35: New job: build yocaml_unix.1.0.0, using opam dev
                              from https://github.com/ocaml/opam-repository.git#refs/pull/24798/head (bdb148b584b0e6a54750fa5a1bb2959d3a9631fc)
                              on debian-12-ocaml-5.1/i386

To reproduce locally:

cd $(mktemp -d)
git clone --recursive "https://github.com/ocaml/opam-repository.git" && cd "opam-repository" && git fetch origin "refs/pull/24798/head" && git reset --hard bdb148b5
git fetch origin master
git merge --no-edit 2dcd8684f95238ebe345f74fa6b964d42688f5b0
cat > ../Dockerfile <<'END-OF-DOCKERFILE'
FROM ocaml/opam:debian-12-ocaml-5.1@sha256:cf5c56c736a07bd16b9161b1972622adfc270cb46eab36137ffe5ea97bdfe6ab
SHELL [ "/usr/bin/linux32", "/bin/sh", "-c" ]
USER 1000:1000
WORKDIR /home/opam
RUN sudo ln -f /usr/bin/opam-dev /usr/bin/opam
RUN opam init --reinit -ni
ENV OPAMDOWNLOADJOBS="1"
ENV OPAMERRLOGLEN="0"
ENV OPAMSOLVERTIMEOUT="500"
ENV OPAMPRECISETRACKING="1"
ENV CI="true"
ENV OPAM_REPO_CI="true"
RUN rm -rf opam-repository/
COPY --chown=1000:1000 . opam-repository/
RUN opam repository set-url --strict default opam-repository/
RUN opam update --depexts || true
ENV OPAMCRITERIA="-removed,-count[avoid-version,changed],-count[version-lag,request],-count[version-lag,changed],-count[missing-depexts,changed],-changed"
ENV OPAMFIXUPCRITERIA="-removed,-count[avoid-version,changed],-count[version-lag,request],-count[version-lag,changed],-count[missing-depexts,changed],-changed"
ENV OPAMUPGRADECRITERIA="-removed,-count[avoid-version,changed],-count[version-lag,request],-count[version-lag,changed],-count[missing-depexts,changed],-changed"
RUN opam pin add -k version -yn yocaml_unix.1.0.0 1.0.0
RUN opam reinstall yocaml_unix.1.0.0; \
    res=$?; \
    test "$res" != 31 && exit "$res"; \
    export OPAMCLI=2.0; \
    build_dir=$(opam var prefix)/.opam-switch/build; \
    failed=$(ls "$build_dir"); \
    partial_fails=""; \
    for pkg in $failed; do \
    if opam show -f x-ci-accept-failures: "$pkg" | grep -qF "\"debian-12\""; then \
    echo "A package failed and has been disabled for CI using the 'x-ci-accept-failures' field."; \
    fi; \
    test "$pkg" != 'yocaml_unix.1.0.0' && partial_fails="$partial_fails $pkg"; \
    done; \
    test "${partial_fails}" != "" && echo "opam-repo-ci detected dependencies failing: ${partial_fails}"; \
    exit 1

END-OF-DOCKERFILE
docker build -f ../Dockerfile .

2023-11-20 17:36.35: Using cache hint "ocaml/opam:debian-12-ocaml-5.1@sha256:cf5c56c736a07bd16b9161b1972622adfc270cb46eab36137ffe5ea97bdfe6ab-yocaml_unix.1.0.0-bdb148b584b0e6a54750fa5a1bb2959d3a9631fc"
2023-11-20 17:36.35: Using OBuilder spec:
((from ocaml/opam:debian-12-ocaml-5.1@sha256:cf5c56c736a07bd16b9161b1972622adfc270cb46eab36137ffe5ea97bdfe6ab)
 (shell /usr/bin/linux32 /bin/sh -c)
 (user (uid 1000) (gid 1000))
 (workdir /home/opam)
 (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
 (run (network host)
      (shell "opam init --reinit --config .opamrc-sandbox -ni"))
 (env OPAMDOWNLOADJOBS 1)
 (env OPAMERRLOGLEN 0)
 (env OPAMSOLVERTIMEOUT 500)
 (env OPAMPRECISETRACKING 1)
 (env CI true)
 (env OPAM_REPO_CI true)
 (run (shell "rm -rf opam-repository/"))
 (copy (src .) (dst opam-repository/))
 (run (shell "opam repository set-url --strict default opam-repository/"))
 (run (network host)
      (shell "opam update --depexts || true"))
 (env OPAMCRITERIA -removed,-count[avoid-version,changed],-count[version-lag,request],-count[version-lag,changed],-count[missing-depexts,changed],-changed)
 (env OPAMFIXUPCRITERIA -removed,-count[avoid-version,changed],-count[version-lag,request],-count[version-lag,changed],-count[missing-depexts,changed],-changed)
 (env OPAMUPGRADECRITERIA -removed,-count[avoid-version,changed],-count[version-lag,request],-count[version-lag,changed],-count[missing-depexts,changed],-changed)
 (run (shell "opam pin add -k version -yn yocaml_unix.1.0.0 1.0.0"))
 (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
      (network host)
      (shell  "opam reinstall yocaml_unix.1.0.0;\
             \n        res=$?;\
             \n        test \"$res\" != 31 && exit \"$res\";\
             \n        export OPAMCLI=2.0;\
             \n        build_dir=$(opam var prefix)/.opam-switch/build;\
             \n        failed=$(ls \"$build_dir\");\
             \n        partial_fails=\"\";\
             \n        for pkg in $failed; do\
             \n          if opam show -f x-ci-accept-failures: \"$pkg\" | grep -qF \"\\\"debian-12\\\"\"; then\
             \n            echo \"A package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\";\
             \n          fi;\
             \n          test \"$pkg\" != 'yocaml_unix.1.0.0' && partial_fails=\"$partial_fails $pkg\";\
             \n        done;\
             \n        test \"${partial_fails}\" != \"\" && echo \"opam-repo-ci detected dependencies failing: ${partial_fails}\";\
             \n        exit 1"))
)

2023-11-20 17:36.35: Waiting for resource in pool OCluster
2023-11-20 23:39.27: Waiting for worker…
2023-11-20 23:40.59: Got resource from pool OCluster
Building on doris.caelum.ci.dev
All commits already cached
Updating files:  85% (27504/32196)
Updating files:  86% (27689/32196)
Updating files:  87% (28011/32196)
Updating files:  88% (28333/32196)
Updating files:  89% (28655/32196)
Updating files:  90% (28977/32196)
Updating files:  91% (29299/32196)
Updating files:  92% (29621/32196)
Updating files:  93% (29943/32196)
Updating files:  94% (30265/32196)
Updating files:  95% (30587/32196)
Updating files:  96% (30909/32196)
Updating files:  97% (31231/32196)
Updating files:  98% (31553/32196)
Updating files:  99% (31875/32196)
Updating files: 100% (32196/32196)
Updating files: 100% (32196/32196), done.
HEAD is now at 2dcd8684f9 Merge pull request #24800 from grainbot/opam-publish-libbinaryen.115.0.0
Merge made by the 'ort' strategy.
 packages/yocaml/yocaml.1.0.0/opam                  | 34 ++++++++++++++++++
 packages/yocaml_cmark/yocaml_cmark.1.0.0/opam      | 38 ++++++++++++++++++++
 packages/yocaml_git/yocaml_git.1.0.0/opam          | 41 +++++++++++++++++++++
 packages/yocaml_jingoo/yocaml_jingoo.1.0.0/opam    | 38 ++++++++++++++++++++
 .../yocaml_markdown/yocaml_markdown.1.0.0/opam     | 38 ++++++++++++++++++++
 .../yocaml_mustache/yocaml_mustache.1.0.0/opam     | 38 ++++++++++++++++++++
 .../yocaml_syndication.1.0.0/opam                  | 37 +++++++++++++++++++
 packages/yocaml_unix/yocaml_unix.1.0.0/opam        | 42 ++++++++++++++++++++++
 packages/yocaml_yaml/yocaml_yaml.1.0.0/opam        | 40 +++++++++++++++++++++
 9 files changed, 346 insertions(+)
 create mode 100644 packages/yocaml/yocaml.1.0.0/opam
 create mode 100644 packages/yocaml_cmark/yocaml_cmark.1.0.0/opam
 create mode 100644 packages/yocaml_git/yocaml_git.1.0.0/opam
 create mode 100644 packages/yocaml_jingoo/yocaml_jingoo.1.0.0/opam
 create mode 100644 packages/yocaml_markdown/yocaml_markdown.1.0.0/opam
 create mode 100644 packages/yocaml_mustache/yocaml_mustache.1.0.0/opam
 create mode 100644 packages/yocaml_syndication/yocaml_syndication.1.0.0/opam
 create mode 100644 packages/yocaml_unix/yocaml_unix.1.0.0/opam
 create mode 100644 packages/yocaml_yaml/yocaml_yaml.1.0.0/opam

(from ocaml/opam:debian-12-ocaml-5.1@sha256:cf5c56c736a07bd16b9161b1972622adfc270cb46eab36137ffe5ea97bdfe6ab)
WARNING: The requested image's platform (linux/386) does not match the detected host platform (linux/amd64) and no specific platform was requested
2023-11-20 23:41.15 ---> saved as "02b1cbe76e92cf5da666f4009bcf833d3ab236729c9e3b7ba2f8614b40ab3ecf"

/: (shell /usr/bin/linux32 /bin/sh -c)

/: (user (uid 1000) (gid 1000))

/: (workdir /home/opam)

/home/opam: (run (shell "sudo ln -f /usr/bin/opam-dev /usr/bin/opam"))
2023-11-20 23:41.15 ---> saved as "0c3c51b8b8452f78cdd5b11674557c7aceac215d27243fc9fe1597ee9357c11a"

/home/opam: (run (network host)
                 (shell "opam init --reinit --config .opamrc-sandbox -ni"))
Configuring from /home/opam/.opamrc-sandbox, then /home/opam/.opamrc, and finally from built-in defaults.
Checking for available remotes: rsync and local, git.
  - you won't be able to use mercurial repositories unless you install the hg command on your system.
  - you won't be able to use darcs repositories unless you install the darcs command on your system.

This development version of opam requires an update to the layout of /home/opam/.opam from version 2.0 to version 2.2~alpha, which can't be reverted.
You may want to back it up before going further.

Continue? [y/n] y
[NOTE] The 'jobs' option was reset, its value was 71 and its new value will vary according to the current number of cores on your machine. You can restore the fixed value using:
           opam option jobs=71 --global
Format upgrade done.

<><> Updating repositories ><><><><><><><><><><><><><><><><><><><><><><><><><><>
[default] synchronised from file:///home/opam/opam-repository
2023-11-20 23:42.45 ---> saved as "78b8c27b033f5a1d52a3f1a997dbfc75803bbdf738a669456980efba48c36421"

/home/opam: (env OPAMDOWNLOADJOBS 1)

/home/opam: (env OPAMERRLOGLEN 0)

/home/opam: (env OPAMSOLVERTIMEOUT 500)

/home/opam: (env OPAMPRECISETRACKING 1)

/home/opam: (env CI true)

/home/opam: (env OPAM_REPO_CI true)

/home/opam: (run (shell "rm -rf opam-repository/"))
2023-11-20 23:43.08 ---> saved as "e7d5bb2a12ddf57304cad73c72c3f3117d5f9ba1c24b2b90f5f1a81b1e37020d"

/home/opam: (copy (src .) (dst opam-repository/))
2023-11-20 23:43.41 ---> saved as "e1800545f6abee6425cc9539a61cf882724e661fdcf4b64355724addcfbe5636"

/home/opam: (run (shell "opam repository set-url --strict default opam-repository/"))
[default] Initialised
2023-11-20 23:44.58 ---> saved as "50b3997ea930189ee623e2deb4d7e64892f98634d54e7be8f992c859ba669069"

/home/opam: (run (network host)
                 (shell "opam update --depexts || true"))
+ /usr/bin/sudo "apt-get" "update"
- Hit:1 http://deb.debian.org/debian bookworm InRelease
- Get:2 http://deb.debian.org/debian bookworm-updates InRelease [52.1 kB]
- Get:3 http://deb.debian.org/debian-security bookworm-security InRelease [48.0 kB]
- Get:4 http://deb.debian.org/debian-security bookworm-security/main i386 Packages [102 kB]
- Fetched 202 kB in 0s (458 kB/s)
- Reading package lists...
- 
2023-11-20 23:44.59 ---> saved as "32b797290430079f79c088524be98de3b5c3b971fcaacda5c64e8d87a63dacf3"

/home/opam: (env OPAMCRITERIA -removed,-count[avoid-version,changed],-count[version-lag,request],-count[version-lag,changed],-count[missing-depexts,changed],-changed)

/home/opam: (env OPAMFIXUPCRITERIA -removed,-count[avoid-version,changed],-count[version-lag,request],-count[version-lag,changed],-count[missing-depexts,changed],-changed)

/home/opam: (env OPAMUPGRADECRITERIA -removed,-count[avoid-version,changed],-count[version-lag,request],-count[version-lag,changed],-count[missing-depexts,changed],-changed)

/home/opam: (run (shell "opam pin add -k version -yn yocaml_unix.1.0.0 1.0.0"))
yocaml_unix is now pinned to version 1.0.0
2023-11-20 23:45.00 ---> saved as "4ffc78bf04a0fcbf34bfe6a4351961a955e52e93ddc8b8fda69eca02c2bc56cc"

/home/opam: (run (cache (opam-archives (target /home/opam/.opam/download-cache)))
                 (network host)
                 (shell  "opam reinstall yocaml_unix.1.0.0;\
                        \n        res=$?;\
                        \n        test \"$res\" != 31 && exit \"$res\";\
                        \n        export OPAMCLI=2.0;\
                        \n        build_dir=$(opam var prefix)/.opam-switch/build;\
                        \n        failed=$(ls \"$build_dir\");\
                        \n        partial_fails=\"\";\
                        \n        for pkg in $failed; do\
                        \n          if opam show -f x-ci-accept-failures: \"$pkg\" | grep -qF \"\\\"debian-12\\\"\"; then\
                        \n            echo \"A package failed and has been disabled for CI using the 'x-ci-accept-failures' field.\";\
                        \n          fi;\
                        \n          test \"$pkg\" != 'yocaml_unix.1.0.0' && partial_fails=\"$partial_fails $pkg\";\
                        \n        done;\
                        \n        test \"${partial_fails}\" != \"\" && echo \"opam-repo-ci detected dependencies failing: ${partial_fails}\";\
                        \n        exit 1"))
yocaml_unix.1.0.0 is not installed. Install it? [y/n] y
  * Incompatible packages:
    - (invariant) -> ocaml-base-compiler >= 5.1.0 -> ocaml-option-bytecode-only
    - yocaml_unix -> conduit-lwt >= 4.0.0 -> sexplib -> num
    You can temporarily relax the switch invariant with `--update-invariant'
  * Incompatible packages:
    - (invariant) -> ocaml-base-compiler >= 5.1.0
    - yocaml_unix -> conduit-lwt >= 4.0.0 -> sexplib -> ocaml < 4.03.0 -> ocaml-variants
  * Missing dependency:
    - yocaml_unix -> conduit-lwt >= 4.0.0 -> sexplib -> ocaml < 4.03.0 -> ocaml-variants -> ocaml-beta
    unmet availability conditions: 'enable-ocaml-beta-repository'
  * Missing dependency:
    - yocaml_unix -> conduit-lwt >= 4.0.0 -> sexplib -> jbuilder >= 1.0+beta10 -> dune < 2.0 -> ocaml < 4.08.0 -> ocaml-base-compiler < 3.07+1 | ocaml-system < 3.07+1 | ocaml-variants < 3.8~
    not available because the package is pinned to version 5.1.0
    unmet availability conditions: 'sys-ocaml-version = "3.07"'
    no matching version
  * Missing dependency:
    - yocaml_unix -> conduit-lwt >= 4.0.0 -> sexplib -> jbuilder >= 1.0+beta10 -> dune < 2.0 -> ocaml < 4.08.0 -> ocaml-base-compiler = 3.07+1 | ocaml-system = 3.07+1 | ocaml-variants < 3.8~
    not available because the package is pinned to version 5.1.0
    unmet availability conditions: 'sys-ocaml-version = "3.07+1"'
    no matching version
  * Missing dependency:
    - yocaml_unix -> conduit-lwt >= 4.0.0 -> sexplib -> jbuilder >= 1.0+beta10 -> dune < 2.0 -> ocaml < 4.08.0 -> ocaml-base-compiler = 3.07+2 | ocaml-system = 3.07+2 | ocaml-variants < 3.8~
    not available because the package is pinned to version 5.1.0
    unmet availability conditions: 'sys-ocaml-version = "3.07+2"'
    no matching version
  * Missing dependency:
    - yocaml_unix -> conduit-lwt >= 4.0.0 -> sexplib -> jbuilder >= 1.0+beta10 -> dune < 2.0 -> ocaml < 4.08.0 -> ocaml-base-compiler = 3.08.0 | ocaml-system >= 3.08.0 | ocaml-variants < 3.08.1~
    not available because the package is pinned to version 5.1.0
    unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.0"'
    no matching version
  * Missing dependency:
    - yocaml_unix -> conduit-lwt >= 4.0.0 -> sexplib -> jbuilder >= 1.0+beta10 -> dune < 2.0 -> ocaml < 4.08.0 -> ocaml-base-compiler = 3.08.1 | ocaml-system >= 3.08.1 | ocaml-variants < 3.08.2~
    not available because the package is pinned to version 5.1.0
    unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.1"'
    no matching version
  * Missing dependency:
    - yocaml_unix -> conduit-lwt >= 4.0.0 -> sexplib -> jbuilder >= 1.0+beta10 -> dune < 2.0 -> ocaml < 4.08.0 -> ocaml-base-compiler = 3.08.2 | ocaml-system >= 3.08.2 | ocaml-variants < 3.08.3~
    not available because the package is pinned to version 5.1.0
    unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.2"'
    no matching version
  * Missing dependency:
    - yocaml_unix -> conduit-lwt >= 4.0.0 -> sexplib -> jbuilder >= 1.0+beta10 -> dune < 2.0 -> ocaml < 4.08.0 -> ocaml-base-compiler = 3.08.3 | ocaml-system >= 3.08.3 | ocaml-variants < 3.08.4~
    not available because the package is pinned to version 5.1.0
    unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.3"'
    no matching version
  * Missing dependency:
    - yocaml_unix -> conduit-lwt >= 4.0.0 -> sexplib -> jbuilder >= 1.0+beta10 -> dune < 2.0 -> ocaml < 4.08.0 -> ocaml-base-compiler = 3.08.4 | ocaml-system >= 3.08.4 | ocaml-variants < 3.08.5~
    not available because the package is pinned to version 5.1.0
    unmet availability conditions, e.g. 'sys-ocaml-version = "3.08.4"'
    no matching version
  * Missing dependency:
    - yocaml_unix -> conduit-lwt >= 4.0.0 -> sexplib -> jbuilder >= 1.0+beta10 -> dune < 2.0 -> ocaml < 4.08.0 -> ocaml-base-compiler = 3.09.0 | ocaml-system >= 3.09.0 | ocaml-variants < 3.09.1~
    not available because the package is pinned to version 5.1.0
    unmet availability conditions, e.g. 'sys-ocaml-version = "3.09.0"'
    no matching version

No solution found, exiting
"/usr/bin/linux32" "/bin/sh" "-c" "opam reinstall yocaml_unix.1.0.0;
        res=$?;
        test "$res" != 31 && exit "$res";
        export OPAMCLI=2.0;
        build_dir=$(opam var prefix)/.opam-switch/build;
        failed=$(ls "$build_dir");
        partial_fails="";
        for pkg in $failed; do
          if opam show -f x-ci-accept-failures: "$pkg" | grep -qF "\"debian-12\""; then
            echo "A package failed and has been disabled for CI using the 'x-ci-accept-failures' field.";
          fi;
          test "$pkg" != 'yocaml_unix.1.0.0' && partial_fails="$partial_fails $pkg";
        done;
        test "${partial_fails}" != "" && echo "opam-repo-ci detected dependencies failing: ${partial_fails}";
        exit 1" failed with exit status 20
2023-11-20 23:45.26: Job failed: Failed: Build failed
2023-11-20 23:45.26: Log analysis:
2023-11-20 23:45.26: >>> 
No solution found, exiting
 (score = 100)
2023-11-20 23:45.26: [SKIP] Package not available